SMF - Installazione appena completata!
openssl pkcs12 -in igesta.p12 -out igesta.pem -nodes -clcerts
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option dns '8.8.8.8'
option netmask '255.255.255.0'
option gateway 192.168.1.1
config interface 'wan'
option proto 'dhcp'
config wifi-device radio0
option type mac80211
option channel 5
option macadam mioMAC
option hwmode 11g
config wifi-iface
option device radio0
option network wan
option mode sta
option ssid miaRete
option encryption psk2
option key pwdMiaRete
option country IT
option country_ie 1
openssl genrsa -des3 -out it.strati.key 2048
openssl req -new -key it.strati.key -out it.strati.csr
openssl x509 -req -days 365 -in it.strati.csr -signkey it.strati.key -out it.strati.crt
cat it.strati.key it.strati.csr it.strati.crt > it.strati.pem
service httpd restart
RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
sudo yum install git-all o (apt-get)
sudo adduser git
sudo passwd git
cd ~
mkdir .ssh
chmod 700 .ssh
touch .ssh/authorized_keys && chmod 600 .ssh/authorized_keys
which git-shell
sudo vim /etc/passwd
sostituire /bin/sh con
/usr/bin/git-shell o quello che da which
git config --global user.name "Nome"
git config --global user.email Nome@sito.it
cat /tmp/id_esempio.pub >> ~/.ssh/authorized_keys
git init --bare